CreateGreaterRule Method (ElementId, ElementId)


Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static FilterRule CreateGreaterRule(
	ElementId parameter,
	ElementId value
)
Visual Basic
Public Shared Function CreateGreaterRule ( _
	parameter As ElementId, _
	value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
	ElementId^ parameter, 
	ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DBElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DBElementId
The user-supplied value against which values from the document will be compared.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also