The id of the template view that controls this view's parameters.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The id of the template view that controls this view's parameters. InvalidElementId if there is no template set for this view.Remarks
Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. Use GetTemplateParameterIds on the template view to get a list of all template parameters. Use GetNonControlledTemplateParameterIds on the template view to get parameters that are not controlled by the template.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | When setting this property: val is not valid as a view template id for this view. |
Autodesk.Revit.ExceptionsArgumentNullException | When setting this property: A non-optional argument was null |