Connects placeholders that looks like Cross connection.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- placeholder1Id
- Type: Autodesk.Revit.DBElementId
The first element Id of pipe placeholder.
- placeholder2Id
- Type: Autodesk.Revit.DBElementId
The second element Id of pipe placeholder that intersects with first one.
- placeholder3Id
- Type: Autodesk.Revit.DBElementId
The third element Id of pipe placeholder that intersects with first one.
Return Value
True if connection succeeds, false otherwise.Remarks
If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The element id placeholder1Id is not pipe placeholder. -or- The element id placeholder2Id is not pipe placeholder. -or- The element id placeholder3Id is not pipe placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder3Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder2Id and placeholder3Id are not collinear. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |