Create Method (Document, ElementId, View)


Creates a new instance of an existing DWG link type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static ImportInstance Create(
	Document document,
	ElementId typeId,
	View DBView
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	typeId As ElementId, _
	DBView As View _
) As ImportInstance
Visual C++
public:
static ImportInstance^ Create(
	Document^ document, 
	ElementId^ typeId, 
	View^ DBView
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document in which to create the new instacne of DWG link type.
typeId
Type: Autodesk.Revit.DBElementId
The element id of the existing DWG link type.
DBView
Type: Autodesk.Revit.DBView
The view into which the new instance of DWG link type will be created.

Return Value

The new instance of the given DWG link type.

Remarks

This function regenerates the input document.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException document is not a project document. -or- document is in an edit mode. -or- The view is not printable. -or- The element id is not of a valid CADLinkType.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also