Connects a trio of placeholders that can intersect in a Tee connection.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- connector1
- Type: Autodesk.Revit.DBConnector
The end connector of the first placeholder.
- connector2
- Type: Autodesk.Revit.DBConnector
The end connector of second placeholder.
- connector3
- Type: Autodesk.Revit.DBConnector
The end connector of the third placeholder.
Return Value
True if connection succeeds, false otherwise.Remarks
The three placeholders may or may not have physical connections. However, the first connector should be collinear with the second connector, and the third connector must have be able to be extended to have an intersection with first and second.
If first placeholder and second placeholder have the same size, the second one is merged with first one and original placeholder element will become invalid. If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |