Gets the id of the RebarHookType that is applied to this Rebar at the bar with index barPositionIndex at the specified end.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barPositionIndex
- Type: SystemInt32
An index between 0 and (NumberOfBarPositions-1).
- end
- Type: SystemInt32
0 for the start hook, 1 for the end hook.
Return Value
The id of a RebarHookType, or invalidElementId if the rebar has no hook at the specified end.Remarks
If this Rebar has Workshop Instructions set to Straight will return the same value for all barPositionIndex between 0 and (NumberOfBarPositions-1). This value will be the same as Rebar.GetHookTypeId(int end).
If this Rebar has Workshop Instructions set to Bent there are different cases:
- All bars are matched exactly with a shape. In this case will return the same value for all barPositionIndex between 0 and (NumberOfBarPositions-1). This value will be the same as Rebar.GetHookTypeId(int end).
- All bars are matched in reversed order with a shape. In this case will return the same value for all barPositionIndex between 0 and (NumberOfBarPositions-1). This value will be the same as Rebar.GetHookTypeId(int end).
- Some bars are matched in reversed order and the others are matched exactly with a shape. In this case for bars that are matched reversed will return the id of the RebarHookType at the opposite end. For the others bars will return the same as Rebar.GetHookTypeId(int end).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | end must be 0 or 1. -or- barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |