RebarShapeConstraintDiameter Constructor


Create a diameter constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public RebarShapeConstraintDiameter(
	ElementId paramId,
	RebarShapeArcReferenceType refType
)
Visual Basic
Public Sub New ( _
	paramId As ElementId, _
	refType As RebarShapeArcReferenceType _
)
Visual C++
public:
RebarShapeConstraintDiameter(
	ElementId^ paramId, 
	RebarShapeArcReferenceType refType
)

Parameters

paramId
Type: Autodesk.Revit.DBElementId
The Id of a Rebar Shape parameter.
refType
Type: Autodesk.Revit.DB.StructureRebarShapeArcReferenceType
A choice of rule for measuring the diameter.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException paramId is not a valid Element identifier.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also