SetDataType Method


Sets the parameter's data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public void SetDataType(
	ForgeTypeId dataType
)
Visual Basic
Public Sub SetDataType ( _
	dataType As ForgeTypeId _
)
Visual C++
public:
void SetDataType(
	ForgeTypeId^ dataType
)

Parameters

dataType
Type: Autodesk.Revit.DBForgeTypeId
The identifier of either a spec or a category. A category identifier indicates a Family Type parameter of that category.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given identifier is neither a spec nor a category.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also