SetPath Method


Sets the railing path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void SetPath(
	CurveLoop curveLoop
)
Visual Basic
Public Sub SetPath ( _
	curveLoop As CurveLoop _
)
Visual C++
public:
void SetPath(
	CurveLoop^ curveLoop
)

Parameters

curveLoop
Type: Autodesk.Revit.DBCurveLoop
The railing path along which the new railing will be created. The curveLoop should be continuous with curves which are only bounded lines and arcs on the same horizontal plane. It also has to have maximum two curves meet in one end point.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The curveLoop must be a single connected path, located on the same horizontal plane and defined using lines or arcs only. It also has to have maximum two curves meet in one end point.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInapplicableDataException The railing has incorrect internal data.

See Also