PreferredJunctionType Property


The preferred junction type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public PreferredJunctionType PreferredJunctionType { get; set; }
Visual Basic
Public Property PreferredJunctionType As PreferredJunctionType
	Get
	Set
Visual C++
public:
property PreferredJunctionType PreferredJunctionType {
	PreferredJunctionType get ();
	void set (PreferredJunctionType value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsDisabledDisciplineException When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also