ReferenceType Property


Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic
Public Property ReferenceType As ReferenceType
	Get
	Set
Visual C++
public:
property ReferenceType ReferenceType {
	ReferenceType get ();
	void set (ReferenceType value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException Thrown when argument is out of range.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when regeneration failed.

See Also