Create Method


Creates a new instance of duct insulation.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static DuctInsulation Create(
	Document document,
	ElementId ductOrContentElementId,
	ElementId ductInsulationTypeId,
	double Thickness
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	ductOrContentElementId As ElementId, _
	ductInsulationTypeId As ElementId, _
	Thickness As Double _
) As DuctInsulation
Visual C++
public:
static DuctInsulation^ Create(
	Document^ document, 
	ElementId^ ductOrContentElementId, 
	ElementId^ ductInsulationTypeId, 
	double Thickness
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
ductOrContentElementId
Type: Autodesk.Revit.DBElementId
The duct , fitting or accessory ElementId to which insulation will be added.
ductInsulationTypeId
Type: Autodesk.Revit.DBElementId
The duct insulation type. If the input duct insulation type is InvalidElementId, the default insulation type from the document will be used.
Thickness
Type: SystemDouble
The thickness of the insulation.

Return Value

The newly created duct insulation.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException This id does not represent a duct, fitting, or accessory element. -or- This duct insulation type is invalid. -or- Thickness is not valid for assignment to insulation or lining elements.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsDisabledDisciplineException None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.ExceptionsInvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also