GetScanOrigin Method


Returns the origin point of a scan in model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public XYZ GetScanOrigin(
	string scanName
)
Visual Basic
Public Function GetScanOrigin ( _
	scanName As String _
) As XYZ
Visual C++
public:
XYZ^ GetScanOrigin(
	String^ scanName
)

Parameters

scanName
Type: SystemString
Name of the scan.

Return Value

Resulting origin point of the scan.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException PointCloudInstance does not contain scan scanName.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also