Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- frameOfReference
- Type: Autodesk.Revit.DBFrame
frameOfReference is an orthonormal frame that defines a local coordinate system for the surface of revolution.- The frame can be "right-handed" or "left-handed".
- The origin of the frame is the base of point of the axis of revolution.
- The BasisZ of the frame is the direction of the axis.
- profileCurve
- Type: Autodesk.Revit.DBCurve
The profile curve, which should satisfy the following conditions:- It is bounded and non-degenerate.
- It is co-planar with the axis of revolution.
- It lies on the xz plane of the frame.
- It lies on the right side of the axis.
- Only the end points of the profile curve can touch the axis.
Return Value
The created surface. Note that this surface may not be of type RevolvedSurface.Remarks
The returned surface may not be of type RevolvedSurface - this function will create a surface of the simplest possible type (Plane, Cylinder, etc.) that can be used to represent the required surface of revolution. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This Frame object may not be used as a local frame of reference. -or- The input profile curve is not valid to create a surface revolution in the given frame. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |