SetLinkedConnectorElement Method


Set the linked connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void SetLinkedConnectorElement(
	ConnectorElement otherConnector
)
Visual Basic
Public Sub SetLinkedConnectorElement ( _
	otherConnector As ConnectorElement _
)
Visual C++
public:
void SetLinkedConnectorElement(
	ConnectorElement^ otherConnector
)

Parameters

otherConnector
Type: Autodesk.Revit.DBConnectorElement
The connector to link to.

Remarks

Set the linked connector to a null reference (Nothing in Visual Basic) to remove the link.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The connector being linked to is a different domain than that of the calling connector. -or- The connector being linked to is the same as the calling connector.
Autodesk.Revit.ExceptionsInvalidOperationException This connector type does not support linked connectors.

See Also