Represents if the parameter values in entries are treated as value range or not.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Notes:
- Only numeric parameter values could be treated as by range.
- There will exist at least two entries if the scheme is by range, and the first entry value should be always Int.MinValue or -Double.MaxValue.
- The entries will always be sorted by ascending in the scheme if it is by range.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | When setting this property: The scheme entries cannot be explained by range. |