Moves this link instance so that the internal origin of the linked document is aligned to the internal origin of the host document. This is a one-time movement and does not set up any shared coordinates relationship.
If the rotation angle of the link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 SubscriptionUpdate
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- resetToOriginalRotation
- Type: SystemBoolean
Sets to true if:
- restoring the original insertion angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.
- there was no a rotation \ mirror transform on the link instance.
Sets to false to retain the current angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.
Remarks
This operation can only be performed on instances of top-level links. The internal origin is not necessarily the same location as the Project Base Point. See MoveBasePointToHostBasePoint(Boolean).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | This RevitLinkInstance is not an instance of a loaded RevitLinkType. -or- This RevitLinkInstance is not an instance of a top-level RevitLinkType. -or- The operation is not permitted because the element is pinned. |