SegmentsRepresentation Property


Identifies how the bending detail will represent the segments of the bar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public BendingDetailSegmentsRepresentation SegmentsRepresentation { get; set; }
Visual Basic
Public Property SegmentsRepresentation As BendingDetailSegmentsRepresentation
	Get
	Set
Visual C++
public:
property BendingDetailSegmentsRepresentation SegmentsRepresentation {
	BendingDetailSegmentsRepresentation get ();
	void set (BendingDetailSegmentsRepresentation value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also