IsCurveValidInView Method


Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public bool IsCurveValidInView(
	DatumExtentType extentMode,
	View view,
	Curve curve
)
Visual Basic
Public Function IsCurveValidInView ( _
	extentMode As DatumExtentType, _
	view As View, _
	curve As Curve _
) As Boolean
Visual C++
public:
bool IsCurveValidInView(
	DatumExtentType extentMode, 
	View^ view, 
	Curve^ curve
)

Parameters

extentMode
Type: Autodesk.Revit.DBDatumExtentType
The extent type.
view
Type: Autodesk.Revit.DBView
The view.
curve
Type: Autodesk.Revit.DBCurve
The curve.

Return Value

True if it is valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also