GetCellFormatOptions Method (Int32, Int32, Document)


Returns a cell's FormatOptions and if no FormatOptions exists for this cell, it would come from the column, or the row, or the section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FormatOptions GetCellFormatOptions(
	int nRow,
	int nCol,
	Document document
)
Visual Basic
Public Function GetCellFormatOptions ( _
	nRow As Integer, _
	nCol As Integer, _
	document As Document _
) As FormatOptions
Visual C++
public:
FormatOptions^ GetCellFormatOptions(
	int nRow, 
	int nCol, 
	Document^ document
)

Parameters

nRow
Type: SystemInt32
nCol
Type: SystemInt32
document
Type: Autodesk.Revit.DBDocument

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given row number nRow is invalid. -or- The given column number nCol is invalid.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also