GetElectricalSettings Method


Get the electrical settings of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static ElectricalSetting GetElectricalSettings(
	Document document
)
Visual Basic
Public Shared Function GetElectricalSettings ( _
	document As Document _
) As ElectricalSetting
Visual C++
public:
static ElectricalSetting^ GetElectricalSettings(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.

Return Value

The electrical settings of the project.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also