Creates a new instance of Structural Section Z Profile shape with the associated set of parameters, used to attach to structural element.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- width
- Type: SystemDouble
Section width.
- height
- Type: SystemDouble
Section height, depth.
- wallNominalThickness
- Type: SystemDouble
Represents wall nominal thickness of rectangle.
- wallDesignThickness
- Type: SystemDouble
Represents wall design thickness of rectangle.
- innerFillet
- Type: SystemDouble
Inner Fillet - Corner fillet inner radius.
- centroidHorizontal
- Type: SystemDouble
Distance from centroid to the left extremites along horizontal axis.
- centroidVertical
- Type: SystemDouble
Distance from centroid to the upper extremites along vertical axis.
- principalAxesAngle
- Type: SystemDouble
Rotation angle between the principal axes and cross section reference planes.
- sectionArea
- Type: SystemDouble
Cross section area.
- perimeter
- Type: SystemDouble
Painting surface of the unit length.
- nominalWeight
- Type: SystemDouble
Unit weight (not mass) per unit length, for self-weight calculation or quantity survey.
- momentOfInertiaStrongAxis
- Type: SystemDouble
Moment of Inertia about main strong axis (I).
- momentOfInertiaWeakAxis
- Type: SystemDouble
Moment of Inertia about main weak axis (I).
- elasticModulusStrongAxis
- Type: SystemDouble
Elastic section modulus about main strong axis for calculation of bending stresses.
- elasticModulusWeakAxis
- Type: SystemDouble
Elastic section modulus about main weak axis for calculation of bending stresses.
- plasticModulusStrongAxis
- Type: SystemDouble
Plastic section modulus in bending about main strong axis (Z, Wpl)
- plasticModulusWeakAxis
- Type: SystemDouble
Plastic section modulus in bending about main weak axis.
- torsionalMomentOfInertia
- Type: SystemDouble
Torsional Moment of inertia (J, IT, K), for calculation of torsional deformation
- torsionalModulus
- Type: SystemDouble
Section modulus for calculations of torsion stresses (Ct)
- warpingConstant
- Type: SystemDouble
Warping constant (Cw, Iomega, H)
- shearAreaStrongAxis
- Type: SystemDouble
Shear area (reduced extreme shear stress coefficient) in the direction of strong axis (Wq).
- shearAreaWeakAxis
- Type: SystemDouble
Shear area (reduced extreme shear stress coefficient) in the direction of weak axis (Wq).
- bottomFlangeLength
- Type: SystemDouble
Bottom Flange segment length.