Returns all numbers currently used in the given numbering sequence
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- partition
- Type: SystemString
Name of the partition that identifies the sequence. The sequence must exist.
Return Value
A collection of integer rangesRemarks
Numbers are returned as a collection of ranges, where each range is a pair of two integer values, Low and High. As long as there is no gap currently in the sequence, there will be only one range.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The sequence partition does not exist in the schema. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |