The position of the leader's end.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
Remarks
Returns the end point of the tag leader. Leader end point must be located inside of a room, space or an area. Use Room.IsPointInRoom or Space.IsPointInSpace method to check whether the leaderEnd is located in the host element or not.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | When setting this property: The point is located outside of the spatial element. |
Autodesk.Revit.ExceptionsArgumentNullException | When setting this property: A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | There is no leader for this tag. -or- When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned. |