CreateDefaultStructuralConnectionHandlerType Method


Creates a new StructuralConnectionHandlerType object with a default name.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static ElementId CreateDefaultStructuralConnectionHandlerType(
	Document pADoc
)
Visual Basic
Public Shared Function CreateDefaultStructuralConnectionHandlerType ( _
	pADoc As Document _
) As ElementId
Visual C++
public:
static ElementId^ CreateDefaultStructuralConnectionHandlerType(
	Document^ pADoc
)

Parameters

pADoc
Type: Autodesk.Revit.DBDocument
The document.

Return Value

The newly created type id.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also