RepresentaionOf3DShapes Property


Identifies how the Bending Detail will represent the 3D shapes.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public BendingDetailFor3DShapesOptions RepresentaionOf3DShapes { get; set; }
Visual Basic
Public Property RepresentaionOf3DShapes As BendingDetailFor3DShapesOptions
	Get
	Set
Visual C++
public:
property BendingDetailFor3DShapesOptions RepresentaionOf3DShapes {
	BendingDetailFor3DShapesOptions get ();
	void set (BendingDetailFor3DShapesOptions value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also