GetUpstreamNodeId Method


Gets the upstream electrical analytical node id.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ElementId GetUpstreamNodeId()
Visual Basic
Public Function GetUpstreamNodeId As ElementId
Visual C++
public:
ElementId^ GetUpstreamNodeId()

Return Value

The upstream node id.

Remarks

If the area based load supplies from Node A, Node A is the upstream node of the area based load, and the area based load is the downstream node of node A.

See Also