Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- outline
- Type: Autodesk.Revit.DBOutline
The Outline used to find elements with a bounding box that are contained by it.
- inverted
- Type: SystemBoolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | outline is an empty Outline. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |