GetCurrent Method


Returns the current Macro module.

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public MacroModule GetCurrent()
Visual Basic
Public Function GetCurrent As MacroModule
Visual C++
public:
MacroModule^ GetCurrent()

Return Value

The current Macro module.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException There is no current item in the iterator.

See Also