AddSize Method


Inserts a new MEPSize into the cable tray sizes. For cable tray, the nominal diameter of MEPSize is used .

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void AddSize(
	MEPSize sizeInfo
)
Visual Basic
Public Sub AddSize ( _
	sizeInfo As MEPSize _
)
Visual C++
public:
void AddSize(
	MEPSize^ sizeInfo
)

Parameters

sizeInfo
Type: Autodesk.Revit.DBMEPSize
The new MEPSize to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException There is already the same size in the size set.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The function is called during iterating the size set.

See Also