Saves cloud model.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.2
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsCentralModelAccessDeniedException | Could be for any of the reasons that related to access to the cloud model. |
Autodesk.Revit.ExceptionsCentralModelContentionException | The central model is locked by another client. |
Autodesk.Revit.ExceptionsCentralModelException | Could be for any of the reasons that fails with CentralModelException, for example, a central model with that name is already associated to the specified cloud project. |
Autodesk.Revit.ExceptionsFileNotFoundException | Cannot access the local file. |
Autodesk.Revit.ExceptionsInvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- Saving is not allowed in the current application mode. -or- This Document does not have a central location: Worksharing needs to be enabled and central model saved. -or- The file is read-only, can not be saved. -or- This Document is a not cloud model, cannot execute this operation. -or- This Document is a workshared document. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. |
Autodesk.Revit.ExceptionsOperationCanceledException | Synchronize With Central was canceled by the user or by an API event callback. |
Autodesk.Revit.ExceptionsRevitServerCommunicationException | Could be for any of the reasons related to network. |
Autodesk.Revit.ExceptionsRevitServerInternalException | Could be for any of the reasons that save fails with RevitServerInternalException. |
Autodesk.Revit.ExceptionsRevitServerUnauthenticatedUserException | User is not signed in with Autodesk id. |
Autodesk.Revit.ExceptionsRevitServerUnauthorizedException | User is not authorized to access the specified cloud project. |