GetPlainText Method (TextRange)


Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public string GetPlainText(
	TextRange textRange
)
Visual Basic
Public Function GetPlainText ( _
	textRange As TextRange _
) As String
Visual C++
public:
String^ GetPlainText(
	TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DBTextRange
The given TextRange.

Return Value

The substring of the text in a plain text form.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also