OpenAndActivateDocument Method (String)


Opens and activates a Revit document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public UIDocument OpenAndActivateDocument(
	string fileName
)
Visual Basic
Public Function OpenAndActivateDocument ( _
	fileName As String _
) As UIDocument
Visual C++
public:
UIDocument^ OpenAndActivateDocument(
	String^ fileName
)

Parameters

fileName
Type: SystemString
A full path to a revit file to be opened. The file can be either a Revit project, template, or family document.

Return Value

The opened document.

Remarks

This method, if successful, changes the active document. It is not allowed to have an open transaction in the active document when calling this method. Additionally, this method may not be called from inside an event handler.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given 'fileName' is not a Revit file (a project, template, or family document).
Autodesk.Revit.ExceptionsArgumentNullException If a null reference (Nothing in Visual Basic) is passed as 'fileName'. -or- A non-optional argument was null
Autodesk.Revit.ExceptionsFileArgumentNotFoundException The file specified by 'fileName' cannot be found.
Autodesk.Revit.ExceptionsInvalidOperationException
  • If the active document is currently modifiable.
  • If an API event handler is currently being executed.
Autodesk.Revit.ExceptionsRevitServerCommunicationException If there is any server internal error.

See Also