GetLinePatternElementByName Method


Retrieves the LinePatternElement by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static LinePatternElement GetLinePatternElementByName(
	Document document,
	string name
)
Visual Basic
Public Shared Function GetLinePatternElementByName ( _
	document As Document, _
	name As String _
) As LinePatternElement
Visual C++
public:
static LinePatternElement^ GetLinePatternElementByName(
	Document^ document, 
	String^ name
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document in which to retrieve the LinePatternElement.
name
Type: SystemString
The name of the LinePatternElement.

Return Value

The LinePatternElement.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also