Current Property


Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual KeyBasedTreeEntry Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyBasedTreeEntry
	Get
Visual C++
public:
virtual property KeyBasedTreeEntry^ Current {
	KeyBasedTreeEntry^ get ();
}

Implements

IEnumeratorTCurrent

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException There is no current item in the iterator.

See Also