AddSegment Method


Add segments to the slab edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override void AddSegment(
	Reference targetRef
)
Visual Basic
Public Overrides Sub AddSegment ( _
	targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
	Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.DBReference
Segment's reference on which want to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException This exception will be thrown in following cases: 1. Input targetRef is a null reference (Nothing in Visual Basic). 2. Input targetRef is not a null reference (Nothing in Visual Basic) but contains nothing.
Autodesk.Revit.ExceptionsInvalidOperationException This exception will be thrown in following cases: 1. Input targetRef has already been added into the slab edge. 2. Internal code fails to create the segment object. 3. Regeneration fails.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException This exception will be thrown if the reference is suitable for creating a slab edge as required. The reference allowed is : 1. Model Line 2. Floor's horizontal edges 3. Other slab edge's horizontal edges

See Also