CreatePointSetIterator Method (PointCloudFilter, ElementId)


Implement this method to return an iterator for iterating over blocks of this point cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
IPointSetIterator CreatePointSetIterator(
	PointCloudFilter rFilter,
	ElementId viewId
)
Visual Basic
Function CreatePointSetIterator ( _
	rFilter As PointCloudFilter, _
	viewId As ElementId _
) As IPointSetIterator
Visual C++
IPointSetIterator^ CreatePointSetIterator(
	PointCloudFilter^ rFilter, 
	ElementId^ viewId
)

Parameters

rFilter
Type: Autodesk.Revit.DB.PointCloudsPointCloudFilter
The filter used to process cloud points and determine which ones lie with the target volume.
viewId
Type: Autodesk.Revit.DBElementId
The view id for the current view passed as auxiliary information to allow the engine to optimize retrieval of points. If viewId == InvalidElementId, the query is not for a view display operation.

Return Value

The newly created iterator.

See Also