The LoadBase object is the base class for all load objects within the Autodesk Revit API. Data members
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
Remarks
Load objects are only available in Autodesk Revit Structure. This object contains methods that are common to all other load objects.
Examples

private void LoadBaseInformation(LoadBase loadBase)
{
string message = "LoadBase data for line load: ";
//Get the name of the load case to which this load belongs
message += "\nLoad case name: " + loadBase.LoadCaseName;
//Get the name of the category to which this load belongs
message += "\nLoad category name: " + loadBase.LoadCategoryName;
//A string representing the nature of the load
message += "\nLoad nature name: " + loadBase.LoadNatureName;
//show the load base information in the messagebox
TaskDialog.Show("Revit",message);
}

Private Sub LoadBaseInformation(loadBase As LoadBase)
Dim message As String = "LoadBase data for line load: "
'Get the name of the load case to which this load belongs
message += vbLf & "Load case name: " & Convert.ToString(loadBase.LoadCaseName)
'Get the name of the category to which this load belongs
message += vbLf & "Load category name: " & Convert.ToString(loadBase.LoadCategoryName)
'A string representing the nature of the load
message += vbLf & "Load nature name: " & Convert.ToString(loadBase.LoadNatureName)
'show the load base information in the messagebox
TaskDialog.Show("Revit", message)
End Sub
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.StructureLoadBase
Autodesk.Revit.DB.StructureAreaLoad
Autodesk.Revit.DB.StructureLineLoad
Autodesk.Revit.DB.StructurePointLoad
Autodesk.Revit.DBElement
Autodesk.Revit.DB.StructureLoadBase
Autodesk.Revit.DB.StructureAreaLoad
Autodesk.Revit.DB.StructureLineLoad
Autodesk.Revit.DB.StructurePointLoad