On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
On a conical surface, the distance between the radial gridlines is not constant. To interpret the Distance property, a circumferential gridline is taken as the "belt." Distance is then measured along the belt. The BeltMeasurement property gives the location of the belt relative to the extremes of the surface. The belt is used whenever gridlines are not parallel. It defaults to 0.5.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | Thrown when beltMeasurement is outside the range [ 0.0, 1.0 ]. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the gridlines are guaranteed to be parallel; check the HasBeltMeasurement property before using this property. |