ExportComplexity Property


Value determines Export Complexity for GreenBuildingXML detailed model export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public gbXMLExportComplexity ExportComplexity { get; set; }
Visual Basic
Public Property ExportComplexity As gbXMLExportComplexity
	Get
	Set
Visual C++
public:
property gbXMLExportComplexity ExportComplexity {
	gbXMLExportComplexity get ();
	void set (gbXMLExportComplexity value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The export complexity does not fall within an appropriate range.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also