AsValueString Method (Document, FormatOptions)


Get the parameter value as a string with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public string AsValueString(
	Document doc,
	FormatOptions options
)
Visual Basic
Public Function AsValueString ( _
	doc As Document, _
	options As FormatOptions _
) As String
Visual C++
public:
String^ AsValueString(
	Document^ doc, 
	FormatOptions^ options
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document to be used to obtain information about the parameter.
options
Type: Autodesk.Revit.DBFormatOptions
Options for formatting the string.

Return Value

The string that represents the parameter value.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also