GetSegmentEndReferenceType Method


Choice of two possibilities for the start and end references of the length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public RebarShapeSegmentEndReferenceType GetSegmentEndReferenceType(
	int index
)
Visual Basic
Public Function GetSegmentEndReferenceType ( _
	index As Integer _
) As RebarShapeSegmentEndReferenceType
Visual C++
public:
RebarShapeSegmentEndReferenceType GetSegmentEndReferenceType(
	int index
)

Parameters

index
Type: SystemInt32
Which reference on the constraint. Either 0 or 1.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException index is not 0 or 1.

See Also