ValidateRiseDropSymbolType Method


Confirms if the parameter is a valid piping rise/drop symbol type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public bool ValidateRiseDropSymbolType(
	RiseDropSymbol risedropType
)
Visual Basic
Public Function ValidateRiseDropSymbolType ( _
	risedropType As RiseDropSymbol _
) As Boolean
Visual C++
public:
bool ValidateRiseDropSymbolType(
	RiseDropSymbol risedropType
)

Parameters

risedropType
Type: Autodesk.Revit.DB.MechanicalRiseDropSymbol
The type.

Return Value

True if the input is a valid piping rise/drop symbol type, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also