SegmentLengthsForArcsDisplayOption Property


Identifies if the arc segment lengths are represented using dimensions or just as text. Only RebarShapes whose definition is RebarShapeDefinitionByArc are considered that have arc segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public BendingDetailSegmentLengthsDisplayOptions SegmentLengthsForArcsDisplayOption { get; set; }
Visual Basic
Public Property SegmentLengthsForArcsDisplayOption As BendingDetailSegmentLengthsDisplayOptions
	Get
	Set
Visual C++
public:
property BendingDetailSegmentLengthsDisplayOptions SegmentLengthsForArcsDisplayOption {
	BendingDetailSegmentLengthsDisplayOptions get ();
	void set (BendingDetailSegmentLengthsDisplayOptions value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also