CheckExportComplexity Method


Checks that the export complexity falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static bool CheckExportComplexity(
	gbXMLExportComplexity exportComplexity
)
Visual Basic
Public Shared Function CheckExportComplexity ( _
	exportComplexity As gbXMLExportComplexity _
) As Boolean
Visual C++
public:
static bool CheckExportComplexity(
	gbXMLExportComplexity exportComplexity
)

Parameters

exportComplexity
Type: Autodesk.Revit.DB.AnalysisgbXMLExportComplexity
The export complexity to be checked.

Return Value

True if the export complexity falls within an appropriate range, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also