GetSegmentByIndex Method


Gets the analytical segment at the specified position.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public MEPAnalyticalSegment GetSegmentByIndex(
	int index
)
Visual Basic
Public Function GetSegmentByIndex ( _
	index As Integer _
) As MEPAnalyticalSegment
Visual C++
public:
MEPAnalyticalSegment^ GetSegmentByIndex(
	int index
)

Parameters

index
Type: SystemInt32
The index where the segment is stored. This index is 0 based.

Return Value

The returned analytical segment.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The index must range from 0 to GetNumberOfSegments()-1.

See Also