ConvertDetailToModelCurves Method


Converts a group of DetailCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArray ConvertDetailToModelCurves(
	View view,
	DetailCurveArray detailCurves
)
Visual Basic
Public Function ConvertDetailToModelCurves ( _
	view As View, _
	detailCurves As DetailCurveArray _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ ConvertDetailToModelCurves(
	View^ view, 
	DetailCurveArray^ detailCurves
)

Parameters

view
Type: Autodesk.Revit.DBView
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
detailCurves
Type: Autodesk.Revit.DBDetailCurveArray
The detail curve array to be converted.

Remarks

This operation will create new ModelCurves with the same geometry of the original detail curves' geometry. The detail curves will be deleted from the document.

Exceptions

ExceptionCondition
SystemArgumentNullException Thrown when the input argument is a null reference (Nothing in Visual Basic).
SystemArgumentException Thrown when the given detail lines are not visible in the given view. Thrown when the detail lines are not in the same view or not parallel to the given view.
SystemInvalidOperationException Thrown when one or more curves could not be successfully converted.

See Also