CreateRibbonPanel Method (Tab, String)


Create a new RibbonPanel on the designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
	Tab tab,
	string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
	tab As Tab, _
	panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
	Tab tab, 
	String^ panelName
)

Parameters

tab
Type: Autodesk.Revit.UITab
The target tab, on which the new panel will be created.
panelName
Type: SystemString
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in Macros.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionpanelName is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptionpanelName is Empty or the tab is not valid.
Autodesk.Revit.ExceptionsInvalidOperationExceptionIf more than 100 panels were created or the tab cannot be found.

See Also