Creates an instance of external event which will have the ability to record its executions in the journal.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- handler
- Type: Autodesk.Revit.UIIExternalEventHandler
An instance of IExternalEventHandler which will execute the event.
Return Value
An instance of ExternalEvent class, which will be used to invoke the eventExceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was NULL |