NewFlexPipe Method (IList(XYZ), FlexPipeType)


Adds a new flexible pipe into the document, using a point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexPipe NewFlexPipe(
	IList<XYZ> points,
	FlexPipeType pipeType
)
Visual Basic
Public Function NewFlexPipe ( _
	points As IList(Of XYZ), _
	pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
	IList<XYZ^>^ points, 
	FlexPipeType^ pipeType
)

Parameters

points
Type: System.Collections.GenericIListXYZ
The point array indicating the path of the flexible pipe, including the end points.
pipeType
Type: Autodesk.Revit.DB.PlumbingFlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument points is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the flexible pipe cannot be created or regenerate fails.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the flexible pipe type does not exist in the given document.

See Also